We have resolved the performance issues on the Swoogo platform and continuing to monitor closely.
Posted Apr 17, 2025 - 05:09 UTC
Update
We are seeing additional reports of slow page load times. Team is investigating.
Posted Apr 17, 2025 - 00:17 UTC
Monitoring
We are seeing significant performance improvement. Team is continuing to monitor and actively working with our cloud provider to ensure this is resolved.
Posted Apr 16, 2025 - 21:49 UTC
Update
We're investigating degraded performance across the platform and we're working with our cloud hosting provider to expedite a resolution.
Posted Apr 16, 2025 - 21:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 16, 2025 - 20:21 UTC
Identified
We're continuing investigation on our end and we're seeing reports of similar site outages across the globe. We'll update here as we learn more.
Posted Apr 16, 2025 - 20:05 UTC
Investigating
We're investigating slow page load times in the Swoogo admin portal. We'll update here as we have more information.
Posted Apr 16, 2025 - 19:47 UTC
This incident affected: Event Registration, Swoogo API, Integrations, and Webhooks.