Swoogo platform errors and slowness

Incident Report for Swoogo

Resolved

This incident has been resolved.
Posted Apr 05, 2025 - 12:11 UTC

Monitoring

We are seeing access to the system restoring. We will be monitoring to ensure system stability and will provide more information when available.
Posted Apr 05, 2025 - 01:22 UTC

Investigating

We're investigating reports of slowness and errors on the Swoogo platform.
Posted Apr 05, 2025 - 00:40 UTC
This incident affected: Event Registration, Swoogo API, Integrations, and Webhooks.